<!DOCTYPE html>
<html lang="en">
  <head>
          <meta charset="utf-8">
      <meta name="viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=5.0">
      <meta http-equiv="X-UA-Compatible" content="ie=edge">

      <title>PS+ Games May 2022: Is this month’s PlayStation Plus line-up any good? | VG247</title>

  <meta property="og:description" content="It&#39;s a pretty good month for PlayStation Plus users that want action-RPGs and sports games in their libraries – but is it good for anyone else?">
  <meta property="og:site_name" content="VG247">
  <meta property="og:title" content="PS+ Games May 2022: Is this month’s PlayStation Plus line-up any good?">
  <meta property="og:type" content="article">
  <meta property="og:url" content="https://www.vg247.com/ps-plus-may-games-any-good-1">
  <meta property="og:image" content="https://asset.vg247.com/ps-plus-may-any-good.jpg/BROK/thumbnail/1600x900/format/jpg/quality/80/ps-plus-may-any-good.jpg">
  <meta property="article:published_time" content="2022-04-29T12:32:27.160393+00:00">
  <meta property="article:tag" content="Action Adventure">
  <meta property="article:tag" content="PS4">
  <meta property="article:tag" content="PS5">
  <meta property="article:tag" content="Sony PlayStation">
  <meta property="article:tag" content="Blockbuster">
  <meta property="article:tag" content="RPG">
  <meta property="article:tag" content="Sports">
  <meta property="article:tag" content="PlayStation">
  <meta property="article:tag" content="Curse Of The Dead Gods">
  <meta property="article:tag" content="Tribes Of Midgard">
  <meta property="article:tag" content="FIFA 22">
  <meta property="article:tag" content="PS Plus May">
  <meta property="article:tag" content="PlayStation Plus">
  <meta property="article:tag" content="Roguelike">
  <meta property="article:tag" content="Hack &amp; Slash">
  <meta property="article:tag" content="Fantasy">

  <meta name="description" content="It&#39;s a pretty good month for PlayStation Plus users that want action-RPGs and sports games in their libraries – but is it good for anyone else?">
  <meta name="twitter:card" content="summary_large_image">
  <meta name="twitter:description" content="It&#39;s a pretty good month for PlayStation Plus users that want action-RPGs and sports games in their libraries – but is it good for anyone else?">
  <meta name="twitter:image" content="https://asset.vg247.com/ps-plus-may-any-good.jpg/BROK/thumbnail/1600x800/format/jpg/quality/80/ps-plus-may-any-good.jpg">
  <meta name="twitter:title" content="PS+ Games May 2022: Is this month’s PlayStation Plus line-up any good?">
  <meta name="twitter:creator" content="@VG247">
  <meta name="twitter:site" content="@VG247">
  <meta name="robots" content="max-image-preview:large">
<link rel="apple-touch-icon" sizes="180x180" href="/static/5803331f89459646734615124fe98b2b/icon/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/static/5803331f89459646734615124fe98b2b/icon/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/static/5803331f89459646734615124fe98b2b/icon/favicon-16x16.png">
<link rel="manifest" href="/static/5803331f89459646734615124fe98b2b/icon/site.webmanifest">
<link rel="mask-icon" href="/static/5803331f89459646734615124fe98b2b/icon/safari-pinned-tab.svg" color="#e73c49">
<meta name="msapplication-TileColor" content="#da532c">
<meta name="theme-color" content="#ffffff">
<script type="application/ld+json">
{
    "@context": "https://schema.org",
    "@type": "NewsArticle",
    "url": "https://www.vg247.com/ps-plus-may-games-any-good-1",
    "mainEntityOfPage": "https://www.vg247.com/ps-plus-may-games-any-good-1",
    "headline": "PS+ Games May 2022: Is this month\u2019s PlayStation Plus line-up any good?",
    "inLanguage": "en",
    "articleSection": "Article",
    "description": "It's a pretty good month for PlayStation Plus users that want action-RPGs and sports games in their libraries \u2013\u00a0but is it good for anyone else?",
    "datePublished": "2022-04-29T12:32:27.160393+00:00",
    "publisher": {
        "@type": "Organization",
        "name": "VG247",
        "url": "https://www.vg247.com/",
        "logo": {
            "@type": "ImageObject",
            "url": "https://asset.vg247.com/vg247-logo.png",
            "width": 192,
            "height": 60
        }
    },
    "image": [
        "https://asset.vg247.com/ps-plus-may-any-good.jpg/BROK/thumbnail/1200x1200/quality/100/ps-plus-may-any-good.jpg",
        "https://asset.vg247.com/ps-plus-may-any-good.jpg/BROK/thumbnail/1200x900/quality/100/ps-plus-may-any-good.jpg",
        "https://asset.vg247.com/ps-plus-may-any-good.jpg/BROK/thumbnail/1600x900/quality/100/ps-plus-may-any-good.jpg"
    ],
    "author": {
        "@context": "https://schema.org",
        "@type": "Person",
        "name": "Dom Peppiatt",
        "jobTitle": "Features Editor",
        "worksFor": {
            "@type": "Organization",
            "name": "VG247",
            "url": "https://www.vg247.com"
        },
        "image": "https://asset.vg247.com/dom_head.jpg",
        "description": "Dom is a veteran video games critic and consultant copywriter that has appeared in publications ranging from Daily Star to The Guardian.\r\n\r\nPassionate about games and the greater good they can achieve, you can usually find Dom listening to records, farting about in the kitchen, or playing Final Fantasy VIII (again).",
        "url": [
            "https://www.vg247.com/authors/dom-peppiatt",
            "https://www.instagram.com/dom_pepin",
            "https://www.linkedin.com/in/dompeppiatt",
            "https://twitter.com/Dom_Pepin"
        ]
    },
    "keywords": [
        "Action Adventure",
        "PS4",
        "PS5",
        "Sony PlayStation",
        "Blockbuster",
        "RPG",
        "Sports",
        "PlayStation",
        "Curse Of The Dead Gods",
        "Tribes Of Midgard",
        "FIFA 22",
        "PS Plus May",
        "PlayStation Plus",
        "Roguelike",
        "Hack & Slash",
        "Fantasy"
    ]
}
</script>



<script type="application/ld+json">
{
    "@context": "https://schema.org",
    "@type": "BreadcrumbList",
    "itemListElement": [
        {
            "@type": "ListItem",
            "position": 1,
            "name": "Home",
            "item": "https://www.vg247.com/"
        },
        {
            "@type": "ListItem",
            "position": 2,
            "name": "Articles",
            "item": "https://www.vg247.com/archive/articles"
        }
    ]
}
</script>

  <script>
    window.dataLayer = window.dataLayer || [];
    function gtag() { dataLayer.push(arguments); }

    function _appendGoogleAnalytics(anonymous) {
        if (window.gtagDone) return;

        gtag('js', new Date());

        const options = {
    "dimension4": "0",
    "dimension5": "0",
    "dimension1": "articles",
    "dimension2": "action-adventure,playstation-4,playstation-5,sony-playstation,blockbuster,rpg,sports-2,playstation,curse-of-the-dead-gods,tribes-of-midgard,fifa-22,ps-plus-may,sony-ps-plus,roguelike,hack-slash,fantasy",
    "dimension3": "Dom Peppiatt",
    "dimension7": "2022-04-29",
    "dimension8": "fifa-22,tribes-of-midgard,curse-of-the-dead-gods"
};

        options['link_attribution'] = true;

        if (anonymous) {
          options['client_storage'] = 'none';
          options['store_gac'] = false;
          options['anonymize_ip'] = true;

            gtag('set', 'allow_ad_personalization_signals', false);

          options['dimension6'] = '1';
        } else {
          options['dimension6'] = '0';
        }

        gtag('config', 'UA-3505225-1', options);

          gtag('config', 'AW-1022621291');

        const gaScript = document.createElement('script');
        gaScript.type = 'text/javascript';
        gaScript.async = true;
        gaScript.src = 'https://www.googletagmanager.com/gtag/js?id=UA-3505225-1';

        document.getElementsByTagName('head')[0].appendChild(gaScript);
        window.gtagDone = true;

        window.dispatchEvent(new Event('BrockmanAnalyticsEnabled'));
    }

    function appendGoogleAnalytics() {
      _appendGoogleAnalytics(false);
    }

    function appendGoogleAnalyticsAnonymous() {
      _appendGoogleAnalytics(true);
    }

    window.addEventListener('BrockmanPerformanceCookiesAllowed', appendGoogleAnalytics);
    window.addEventListener('BrockmanPerformanceCookiesDisallowed', appendGoogleAnalyticsAnonymous);
  </script>
  <script>
      window.PARSELY = window.PARSELY || {
        autotrack: false,
        onReady: function() {
          PARSELY.updateDefaults({
            data: {
    "user": "unregistered"
}
          });
          PARSELY.beacon.trackPageView();
        }
      };

    function appendParsely() {
        if (window.parselyDone) return;
        (function(d) {
          var b = d.body;
          var e = d.createElement('script');
          e.id = 'parsely-cfg';
          e.src = '//cdn.parsely.com/keys/vg247.com/p.js';
          b.appendChild(e);
        })(document);
        window.parselyDone = true;
    }

    window.addEventListener('BrockmanPerformanceCookiesAllowed', appendParsely);
  </script>

  <script>
    window.mainScriptsEvent = document.createEvent('CustomEvent');
    window.mainScriptsEvent.initCustomEvent('mainScripts');
  </script>
  <script defer src="/static/5803331f89459646734615124fe98b2b/js/main.min.js" onload="window.dispatchEvent(window.mainScriptsEvent)"></script>

<script>
  window.addEventListener('mainScripts', function() {
    window.BrockmanLazyLoad = new BrockmanLazyLoad();
    window.BrockmanLazyLoad.run();
  });
</script>
<script>
  window.addEventListener('mainScripts', function() {
    window.BrockmanLightbox = new BrockmanLightbox({});
    window.BrockmanLightbox.run();
  });
</script>

  <script>
    window.commercialScriptsEvent = document.createEvent('CustomEvent');
    window.commercialScriptsEvent.initCustomEvent('commercialScripts');
  </script>
  <script defer src="/static/5803331f89459646734615124fe98b2b/js/commercial.min.js" onload="window.dispatchEvent(window.commercialScriptsEvent)"></script>

  <script>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</script>


  <link rel="preload" href="https://securepubads.g.doubleclick.net/tag/js/gpt.js" as="script">
  <link rel="preload" href="https://c.amazon-adsystem.com/aax2/apstag.js" as="script">

<script>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</script>
  <script>
    function appendCarbon() {
      !function(a,l,b,c,k,s,t,g,A){a.CustomerConnectAnalytics=k,a[k]=a[k]||function(){
      (a[k].q=a[k].q||[]).push(arguments)},g=l.createElement(b),A=l.getElementsByTagName(b)[0],
      g.type="text/javascript",g.async=!0,g.src=c+"?id="+s+"&parentId="+t,A.parentNode.insertBefore(g,A)
      }(window,document,"script","//carbon-cdn.ccgateway.net/script","cca",window.location.hostname,"04d6b31292");
    }
    window.addEventListener('BrockmanTCFConsent', appendCarbon);
  </script>


<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: '2', c2: '8518622', cs_ucfr: '' });

  function appendComscore(cs_ucfr_value) {
    (self.COMSCORE && COMSCORE.beacon({ c1: "2", c2: "8518622", cs_ucfr: cs_ucfr_value }));
    if (window.comscoreDone) return;
    _comscore[0].cs_ucfr = cs_ucfr_value;
    const s = document.createElement("script");
    const el = document.getElementsByTagName("script")[0];
    s.type = 'text/javascript';
    s.async = true;
    s.src = 'https://sb.scorecardresearch.com/cs/8518622/beacon.js';
    el.parentNode.insertBefore(s, el);
    window.comscoreDone = true;
  }

  window.addEventListener('BrockmanTargetingCookiesDisallowed', () => appendComscore(0));
  window.addEventListener('BrockmanTargetingCookiesAllowed', () => appendComscore(1));
</script>


  <script>
    function appendSkimlinks() {
      if (window.skimlinksDone) return;
      const skimlinksScript = document.createElement('script');
      skimlinksScript.type = 'text/javascript';
      skimlinksScript.async = true;
      skimlinksScript.src = 'https://s.skimresources.com/js/87431X1540266.skimlinks.js';
      document.getElementsByTagName('head')[0].appendChild(skimlinksScript);
      window.skimlinksDone = true;
    }

    window.addEventListener('BrockmanTargetingCookiesAllowed', appendSkimlinks);
  </script>

  <script>
    function appendFacebookPixels() {
      if (window.facebookPixelsDone) return;
      !function(f,b,e,v,n,t,s)
      {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
      n.callMethod.apply(n,arguments):n.queue.push(arguments)};
      if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
      n.queue=[];t=b.createElement(e);t.async=!0;
      t.src=v;s=b.getElementsByTagName(e)[0];
      s.parentNode.insertBefore(t,s)}(window, document,'script',
      'https://connect.facebook.net/en_US/fbevents.js');

        fbq('init', '1749355691872662');

      fbq('track', 'PageView');
      window.facebookPixelsDone = true;

      window.dispatchEvent(new Event('BrockmanFacebookPixelsEnabled'));
    }

    window.addEventListener('BrockmanTargetingCookiesAllowed', appendFacebookPixels);
  </script>


    <script>
    window.articleScriptsEvent = document.createEvent('CustomEvent');
    window.articleScriptsEvent.initCustomEvent('articleScripts');
  </script>
  <script defer src="/static/5803331f89459646734615124fe98b2b/js/article.min.js" onload="window.dispatchEvent(window.articleScriptsEvent)"></script>

  <script>
    window.addEventListener('articleScripts', function() {
      window.BrockmanEdmonds = new BrockmanEdmonds({
        selector: '.edmonds-block',
        site: 'vg247.com',
        edmonds_url: 'https://edmonds.gamer-network.net',
      });
      window.BrockmanEdmonds.run();
    });
  </script>





  <script defer src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" type="text/javascript" charset="UTF-8" data-domain-script="3e103126-0f7b-447b-8f8c-704bca5f2cad"></script>

<script>
  function enableElements() {
    const elements = document.querySelectorAll('iframe[data-src], script[data-src], img[data-src]');
    for (let i = 0; i < elements.length; i ++) {
      const element = elements[i];
      element.setAttribute('src', element.dataset.src);
    }
  }

  function showEmbedPlaceholders() {
    if (window.embedPlaceholdersDone) return;
    const elements = document.querySelectorAll('.embed_placeholder');
    for (let i = 0; i < elements.length; i ++) {
      const element = elements[i];
      element.style.display = '';
    }
    window.embedPlaceholdersDone = true;
  }

  function hidePerformanceEmbedPlaceholders() {
    hideEmbedPlaceholders('performance');
  }

  function hideFunctionalEmbedPlaceholders() {
    hideEmbedPlaceholders('functional');
  }

  function hideTargetingEmbedPlaceholders() {
    hideEmbedPlaceholders('targeting');
  }

  function hideEmbedPlaceholders(type) {
    const identifier = '.embed_placeholder' + (type ? '[data-type="' + type + '"]' : '');
    const elements = document.querySelectorAll(identifier);
    for (let i = 0; i < elements.length; i ++) {
      const element = elements[i];
      element.style.display = 'none';
    }
  }

  function performanceCookiesAllowed() {
    window.dispatchEvent(new Event('BrockmanPerformanceCookiesAllowed'));
    hidePerformanceEmbedPlaceholders();
  }

  function performanceCookiesDisallowed() {
    window.dispatchEvent(new Event('BrockmanPerformanceCookiesDisallowed'));
  }

  function functionalCookiesAllowed() {
    window.dispatchEvent(new Event('BrockmanFunctionalCookiesAllowed'));
    hideFunctionalEmbedPlaceholders();
  }

  function functionalCookiesDisallowed() {
    window.dispatchEvent(new Event('BrockmanFunctionalCookiesDisallowed'));
  }

  function targetingCookiesAllowed() {
    window.dispatchEvent(new Event('BrockmanTargetingCookiesAllowed'));
    enableElements();
    hideTargetingEmbedPlaceholders();
  }

  function targetingCookiesDisallowed() {
    window.dispatchEvent(new Event('BrockmanTargetingCookiesDisallowed'));
  }


    function OptanonWrapper() {
        window.BrockmanAllowedCookies = {
          performance: OptanonActiveGroups.match(/,2,/) !== null,
          functional: OptanonActiveGroups.match(/,3,/) !== null,
          targeting: OptanonActiveGroups.match(/,4,/) !== null,
        };

        showEmbedPlaceholders();

        window.BrockmanAllowedCookies.performance ?
          performanceCookiesAllowed() : performanceCookiesDisallowed();

        window.BrockmanAllowedCookies.functional ?
          functionalCookiesAllowed() : functionalCookiesDisallowed();

        window.BrockmanAllowedCookies.targeting ?
          targetingCookiesAllowed() : targetingCookiesDisallowed();

        window.dispatchEvent(new Event('BrockmanLoadAds'));
    }
</script>
  <style>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</style>

        <link rel="canonical" href="https://www.vg247.com/ps-plus-may-games-any-good-1">

      <link rel="alternate" type="application/rss+xml" href="https://www.vg247.com/feed">




    <script>
      function appendApester() {
        if (window.apesterDone) return;

        const apesterScript = document.createElement('script');
        apesterScript.async = true;
        apesterScript.src = '//static.apester.com/js/sdk/v2.0/apester-javascript-sdk.min.js';
        document.getElementsByTagName('head')[0].appendChild(apesterScript);

        window.apesterDone = true;
      }

      window.addEventListener('BrockmanTargetingCookiesAllowed', appendApester);
    </script>
  </head>
  <body
      data-version="hd"
      data-page="article"
      data-ads="true"
      data-affiliates="true"
      data-menu="false"
  >
    <div id="app_wrapper">
        <header class="app_header">


  <nav class="nav_trending">
            <span class="label">Trending</span>


        <ul>
                  <li>
                    <a
                      href="https://www.vg247.com/elden-ring-best-classes-origin"
                      data-active="false"
                      
                    >
                        Elden Ring Best Class
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.vg247.com/elden-ring-guide-beginners"
                      data-active="false"
                      
                    >
                        Elden Ring Beginner&#39;s Guide
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.vg247.com/elden-ring-boss-order-required-optional"
                      data-active="false"
                      
                    >
                        Elden Ring Boss Order
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.vg247.com/roblox-blox-fruits-codes"
                      data-active="false"
                      
                    >
                        Blox Fruits Codes
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.vg247.com/lego-star-wars-skywalker-saga-codes"
                      data-active="false"
                      
                    >
                        LEGO Star Wars Skywalker Saga codes
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.vg247.com/best-game-pass-games-xbox-pc"
                      data-active="false"
                      
                    >
                        Best Game Pass Games
                    </a>
                  </li>
        </ul>
  </nav>
  <nav class="nav_main">


<a
  href="/"
  class="logo"
  
>
    <img src="https://asset.vg247.com/0314_vg247-logo-inverse_xiNfZY6.svg" alt="VG247 logo" loading="eager">
</a>


  <nav class="nav_primary">
        

        <ul>
                  <li>
                    <a
                      href="/archive/news"
                      data-active="false"
                      
                    >
                        News
                    </a>
                  </li>
                  <li>
                    <a
                      href="/archive/reviews"
                      data-active="false"
                      
                    >
                        Reviews
                    </a>
                  </li>
                  <li>
                    <a
                      href="/archive/articles"
                      data-active="false"
                      
                    >
                        Articles
                    </a>
                  </li>
                  <li>
                    <a
                      href="/archive/guides"
                      data-active="false"
                      
                    >
                        Guides
                    </a>
                  </li>
        </ul>
  </nav>



  <nav class="nav_secondary">
        

        <ul>
                  <li>
                    <a
                      href="/topics/deals"
                      data-active="false"
                      
                    >
                        Deals
                    </a>
                  </li>
                  <li>
                    <a
                      href="/games/genshin-impact"
                      data-active="false"
                      
                    >
                        Genshin Impact
                    </a>
                  </li>
                  <li>
                    <a
                      href="/games/pokemon-go"
                      data-active="false"
                      
                    >
                        Pokémon Go
                    </a>
                  </li>
                  <li>
                    <a
                      href="/games/elden-ring"
                      data-active="false"
                      
                    >
                        Elden Ring
                    </a>
                  </li>
        </ul>
  </nav>


  <div class="actions">
        <div class="user_profile signed_out">
    <div class="button_group">
        <a class="button small login" href="/community/auth/start?next=/ps-plus-may-games-any-good-1" rel="nofollow">Sign in / Create account</a>
    </div>
  </div>

<div class="commercial">
      <a href="/subscribe/standard" class="button supporter">
        Support us
      </a>


  <a
    href="https://store.reedpop.com/collections/vg247"
    target="_blank"
    rel="noopener"
    class="button store"
  >
    Visit our store
  </a>
</div>  </div>
  </nav>
        </header>

        <main id="page_wrapper">
  <div class="advert_container leaderboard_container">
    <div class="advert leaderboard"
      data-dfp-id="VG_LB_1"
      data-dfp-sizes="300x250, 320x50, 728x90, 960x160, 960x250, 970x250, 1260x110, 1260x160, 1260x200, 1260x250"
      data-dfp-targeting="site=vg247.com"
      id="VG_LB_1_1"
    ></div>
  </div>

              <div id="content">
  <div id="content_above">
        <div class="page_content">


<div class="disclaimer">
If you click on a link and make a purchase we may receive a small commission.  <a href="/editorial-policy">Read our editorial policy</a>.
</div>
  <article
    class="article "
data-ads="true"
data-article-type="articles"
data-paywalled="false"
data-premium="false"
data-type="article"
  >

<header class="article_header">
  <div class="breadcrumbs">
  

  <nav class="nav_breadcrumbs">
        

        <ul>
                  <li>
                    <a
                      href="/"
                      data-active="false"
                      
                    >
                        Home
                    </a>
                  </li>
                  <li>
                    <a
                      href="/archive/articles"
                      data-active="false"
                      
                    >
                        Articles
                    </a>
                  </li>
        </ul>
  </nav>

    <span class="kicker">that&#39;s a plus</span>
  </div>

    <div class="details">
        <h1 class="title">    PS+ Games May 2022: Is this month’s PlayStation Plus line-up any&nbsp;good?
</h1>

        <span class="strapline">It&#39;s a pretty good month for PlayStation Plus users that want action-RPGs and sports games in their libraries – but is it good for anyone else?</span>

    </div>

    <div class="metadata">

<div class="avatar">
  <img
    src="https://asset.vg247.com/dom_head.jpg/BROK/thumbnail/70x70/quality/60/dom_head.jpg"
    srcset="https://asset.vg247.com/dom_head.jpg/BROK/thumbnail/70x70/quality/60/dom_head.jpg 1x, https://asset.vg247.com/dom_head.jpg/BROK/thumbnail/140x140/quality/60/dom_head.jpg 2x"
loading="lazy"    class="avatar_image"
    alt="Dom Peppiatt avatar"
width="70"height="70"  >
</div>
        <div class="author">
              <span class="article_type" data-slug="articles">
                Article
              </span>

<span class="by">by</span> <span class="name">                  <a href="/authors/dom-peppiatt">Dom Peppiatt</a>
</span>                <span class="job_title">
                    Features Editor
                </span>
        </div>


        <div class="published_at">
Published on <time datetime="2022-04-29 12:32:27.160393+00:00">April 29, 2022</time>        </div>

    </div>





<div class="headline_asset">
  <figure class="headline_image_wrapper">
  <a
    href="https://asset.vg247.com/ps-plus-may-any-good.jpg/BROK/resize/1920x1920%3E/format/jpg/quality/80/ps-plus-may-any-good.jpg"
    target="_blank"
    data-lightbox="true"
  >
  <img
    src="https://asset.vg247.com/ps-plus-may-any-good.jpg/BROK/resize/690%3E/format/jpg/quality/80/ps-plus-may-any-good.jpg"
    srcset="https://asset.vg247.com/ps-plus-may-any-good.jpg/BROK/resize/690%3E/format/jpg/quality/80/ps-plus-may-any-good.jpg 1x, https://asset.vg247.com/ps-plus-may-any-good.jpg/BROK/resize/1380%3E/format/jpg/quality/80/ps-plus-may-any-good.jpg 2x"
loading="eager"    class="headline_image"
    alt=""
width="690"height="388"  >
  </a>

  </figure>
</div>
</header>  <div class="article_body">

        <div class="article_body_content">



            <p><strong>Sony</strong> has officially announced its <strong>May 2022 PlayStation Plus</strong> line-up &ndash; and it's a good one. As ever, <a href="https://www.vg247.com/playstation-plus-may-2022-games-ps4-ps5">the actual line-up leaked</a> a little while ago, but now that we've had <a href="https://www.vg247.com/playstation-plus-may-games-confirmed-as-fifa-22-tribes-of-midgard-and-curse-of-the-dead-gods">official confirmation</a> from Sony about what to expect, we've been mulling it over and we've come to a conclusion &ndash; this really is a pretty good month for the subscription service.</p>
<p>To recap, the games you'll be able to download from May 3 are: <strong>FIFA 22</strong> (PS4, PS5), <strong>Tribes of Midgard</strong> (PS4, PS5), and <strong>Curse of the Dead Gods</strong> (PS4). You have until May 2 to download <a href="https://www.vg247.com/playstation-plus-free-games-for-april-2022-confirmed">April's PS Plus games</a> &ndash; check those out at the link.</p>
<p>Perhaps that's because Sony is trying to sew as much positive sentiment as possible ahead of <a href="https://www.vg247.com/playstation-plus-premium-xbox-game-pass-reaction">the relaunch of PlayStation Plus</a> and it's more expensive (and somewhat controversial) Premium option. What better way to prove to players and payers alike that the service is still worth your hard-earned money than letting the traditional tier of the service go out with a proverbial bang?</p>
<div class="blue_billywig">
<figure class="video_wrapper bluebillywig">
<script async data-cookies-src="https://gamernetwork.bbvms.com/p/vg247_autoplay/c/4723049.js" data-lazyload="true" data-nocookies-src="https://gamernetwork.bbvms.com/p/vg247_no_cookies/c/4723049.js"></script>
</figure>
<a class="button" href="https://www.youtube.com/watch?v=D9jo-Yj95rw" rel="noopener" target="_blank">
Watch on YouTube    </a>
</div>
<p>So, let's see how good these games are.</p>
<p><strong>FIFA 22</strong>: Unless you've been living under a rock, you'll know about this game &ndash; FIFA 22 is a game with plenty of solid improvements compared to past iterations of the franchise, but many argue that the game is let down deeply by an aggressive and insidious monetisation programme.</p> 

  

The game currently endures <a href="https://www.metacritic.com/game/playstation-5/fifa-22/user-reviews">a 2.6 user score</a> on Metacritic (<a href="https://www.metacritic.com/game/playstation-5/fifa-22/critic-reviews">78 on the critic side</a>), with the vast amount of criticism being levied at the game's unscrupulous monetization tactics. The pace is slower than previous games, and there's more of a focus on 1v1 encounters with ball skills and things like that. 

  

<p>Let's be honest, though; this game is on PS Plus in May. It's a big thing for a FIFA title &ndash; especially a current one. It's obvious that this is EA trying to get the title in more players' hands, so it can harvest more money from them in the form of the FIFA coins premium currency. But if you want to play it, you want to play it &ndash; and there's probably very little that's going to change your mind. It's not like Konami's eFootball (or even the mysterious UFL) has any chance at holding FIFA off the football throne in the immediate future.</p>
<figure class="video_wrapper youtube">
<iframe allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen data-src="https://www.youtube.com/embed/p-rpS-9SNSs?autoplay=0" frameborder="0" loading="lazy" src="https://www.youtube-nocookie.com/embed/p-rpS-9SNSs?autoplay=0">
</iframe></figure>
<p><strong>Tribes of Midgard</strong>: This is a title that blends survival and ARPG genres into an experience set within Norse mythology. Playable in solo or co-op, as an Einherjar returned to life by Odin, you and your tribe of up to 10 players are tasked with defending the Seed of Yggdrasil from evil forces set on bringing about Ragnarok.</p>
<p>This is a Diablo-inspired RPG in which you will need to gather resources, materials, and treasures in order to forge new weapons and armor. By all accounts, there's a great cadence to progression, and you're able to get hooked on the many interlocking systems as the game opens up. The end-game? Take on giants and beasts of Norse legend and reign victorious.</p>
<p>The PS5 game <a href="https://www.metacritic.com/game/playstation-5/tribes-of-midgard/critic-reviews">has a respectable 71 on Metacritic</a>, with most critics complimenting the co-op action, launch offering, and graphical style of the title. Sure, it can be repetitive &ndash; but that's largely the appeal of these types of games in some ways, right? Come for the difficulty curve, stay for the end-game.</p>
<figure class="video_wrapper youtube">
<iframe allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen data-src="https://www.youtube.com/embed/Bj3nbHa76cY?autoplay=0" frameborder="0" loading="lazy" src="https://www.youtube-nocookie.com/embed/Bj3nbHa76cY?autoplay=0">
</iframe></figure>
<p><strong>Curse of the Dead Gods</strong>: If you're a fan of skill-based, single-player roguelikes, look no further. In this PS4 game &ndash; <a href="https://www.metacritic.com/game/playstation-4/curse-of-the-dead-gods">which sits at 79 on Metacritic</a> &ndash; you will explore a cursed temple which is a seemingly endless labyrinth full of bottomless pits, traps, and monsters. Here, even death is not an escape, because upon every death, you will rise to fight again. Par for the course in the genre, then.</p>
<p>Though a lot of reviews say the game falls down when compared to genre stablemates like Binding of Isaac, Hades, or even Enter The Gungeon &ndash; it's still a playful, satisfying romp in its own right. Visually striking and compelling (once you really get your teeth into it), this tricky action-packed game has certainly made its way onto my radar thanks to its PS Plus inclusion. <a href="https://www.vg247.com/ps-plus-april-slay-the-spire">Let's see if I can ever stop playing Slay the Spire</a>, though.</p>
<p>So there you have it, May's PS Plus line-up. What do you think? Anything here you're definitely going to play (or avoid)? Let us know in the comments below.</p>

        </div>




  </div>
  </article>

<footer class="article_footer">


  <div class="tagged_with">
      <h2 class="section_title small">Tagged With</h2>
    <ul>
        <li>
          <a href="/genres/action-adventure">Action Adventure</a>
        </li>
        <li>
          <a href="/genres/blockbuster">Blockbuster</a>
        </li>
        <li>
          <a href="/games/curse-of-the-dead-gods">Curse Of The Dead Gods</a>
        </li>
        <li>
          <a href="/genres/fantasy">Fantasy</a>
        </li>
        <li>
          <a href="/games/fifa-22">FIFA 22</a>
        </li>
        <li>
          <a href="/genres/hack-slash">Hack &amp; Slash</a>
        </li>
        <li>
          <a href="/companies/playstation">PlayStation</a>
        </li>
        <li>
          <a href="/topics/sony-ps-plus">PlayStation Plus</a>
        </li>
        <li>
          <a href="/topics/ps-plus-may">PS Plus May</a>
        </li>
        <li>
          <a href="/platforms/playstation-4">PS4</a>
        </li>
        <li>
          <a href="/platforms/playstation-5">PS5</a>
        </li>
        <li>
          <a href="/genres/roguelike">Roguelike</a>
        </li>
        <li>
          <a href="/genres/rpg">RPG</a>
        </li>
        <li>
          <a href="/companies/sony-playstation">Sony PlayStation</a>
        </li>
        <li>
          <a href="/genres/sports-2">Sports</a>
        </li>
        <li>
          <a href="/games/tribes-of-midgard">Tribes Of Midgard</a>
        </li>
    </ul>
  </div>

    <div class="author_bio compact">
      <h2 class="section_title small">About the Author</h2>





<article class="summary" data-type="persona">
    <a
      href="/authors/dom-peppiatt"
      class="link_overlay"
      title="Dom Peppiatt"
    ></a>

<div class="avatar">
  <img
    src="https://asset.vg247.com/dom_head.jpg/BROK/thumbnail/70x70/quality/60/dom_head.jpg"
    srcset="https://asset.vg247.com/dom_head.jpg/BROK/thumbnail/70x70/quality/60/dom_head.jpg 1x, https://asset.vg247.com/dom_head.jpg/BROK/thumbnail/140x140/quality/60/dom_head.jpg 2x"
loading="lazy"    class="avatar_image"
    alt="Dom Peppiatt avatar"
width="70"height="70"  >
</div>
  <div class="details">
        <p class="name">
            <a href="/authors/dom-peppiatt">Dom Peppiatt</a>
        </p>

      <p class="job_title">
        Features Editor
      </p>


        <p class="bio">
          Dom is a veteran video games critic and consultant copywriter that has appeared in publications ranging from Daily Star to The Guardian.

Passionate about games and the greater good they can achieve, you can usually find Dom listening to records, farting about in the kitchen, or playing Final Fantasy VIII (again).
        </p>
  </div>
</article>  </div>



<div class="supporters_promo">
  <h3>Support VG247</h3>
  <p>You give us money, we give you an ad-free reading experience, merch discounts, a newsletter every month, and elite status amongst your friends.</p>
  <a class="button outline" href="/subscribe/standard">See more information</a>
</div>
<div id="comments">
  <div class="container"></div>

  <noscript>
    <p class="alert error">
Please enable JavaScript to see comments.    </p>
  </noscript>

  <script>
    window.addEventListener('articleScripts', () => {
      window.BrockmanComments = new BrockmanComments({
          id: '/community/thread/wzyrjdmn0xnj1m5p',
          postCount: '0',
          previewEndpoint: '/community/preview',
          loc: {
            commentError: `Sorry, but an error occurred. Please try again.`,
            emptyCommentError: `You need to write a response to submit a comment.`,
            errorMessage: `Comments failed to load.`,
            genericError: `Sorry, something went wrong.`,
            labelNoResponse: `Write a response to this article`,
            labelResponse: `See all responses to this article`,
            loading: `Loading`,
            postComment: `Post comment`,
            submittedComment: `Comment submitted. Thanks for contributing!`,
            writeComment: `Write a spectacular comment`,
            like: `Like`,
            unavailableLike: `You are not able to like this comment`,
            reportSubmitted: `Thank you for submitting a report about this comment. Your report will be added to a queue for our moderation team to review.`,
            emptyReportReason: `Please select a reason from the list for your report to be processed.`,
          },
      });
    });
  </script>
</div></footer>      </div>


  <div class="sidebar">
  <div class="advert_container halfpage_container">
    <div class="advert mpu"
      data-dfp-id="VG_HP"
      data-dfp-sizes="300x600, 300x250, 300x1050"
      data-dfp-targeting="site=vg247.com"
      id="VG_HP_1"
        data-dfp-collapse="true"
    ></div>
  </div>

      <div class="gn_sidebar"></div>
  </div>
  </div>

  <div id="content_below">
      <div class="page_content">
    <div class="advert_container low_leaderboard_container">
    <div class="lazyload low_leaderboard"
      data-dfp-id="VG_LB_2"
      data-dfp-sizes="300x250, 320x50, 728x90, 960x160, 960x250, 970x250, 1200x500"
      data-dfp-targeting="site=vg247.com"
      id="VG_LB_2_AFTER_ARTICLE"
        data-dfp-collapse="true"
    ></div>
  </div>





      <section class="shelf" data-count="4" >
    <div class="section_title_wrapper">
      <h2 class="section_title">More Articles</h2>
    </div>



      <ul class="summary_list">
          <li>




<article
  class="summary"
  data-type="article"
  data-article-type="articles"
  data-premium="false"
  data-size="default"
>
    <a href="https://www.vg247.com/ps-plus-premium-demos-are-good" class="link_overlay" title="With PS+ Premium, I hope everyone gets to experience the joy of game demos again" ></a>




<div class="thumbnail">
  <img
    src="https://asset.vg247.com/demo-one-demos-are-good.jpg/BROK/thumbnail/299x168/format/jpg/quality/70/demo-one-demos-are-good.jpg"
    srcset="https://asset.vg247.com/demo-one-demos-are-good.jpg/BROK/thumbnail/299x168/format/jpg/quality/70/demo-one-demos-are-good.jpg 1x, https://asset.vg247.com/demo-one-demos-are-good.jpg/BROK/thumbnail/598x336/format/jpg/quality/70/demo-one-demos-are-good.jpg 2x"
loading="lazy"    class="thumbnail_image"
    alt="Image for With PS+ Premium, I hope everyone gets to experience the joy of game demos again"
width="299"height="168"  >
</div>
    <div class="details">

            <div class="kicker_wrapper">
              <span class="kicker">try your heart out</span>
            </div>

          <p class="title">
<a href="https://www.vg247.com/ps-plus-premium-demos-are-good" >                With PS+ Premium, I hope everyone gets to experience the joy of game demos again
</a>          </p>

            <p class="strapline">Game demos are a strain on developers. But as a consumer, they’re an incredible tool.</p>

    </div>

    <div class="metadata">
    <span class="author">Dom Peppiatt</span>

  <div class="article_data">
      <time class="published_at" datetime="2022-04-29 15:52:37.985158+00:00">
          2 hours ago

      </time>
  </div>
    </div>

</article>          </li>
          <li>




<article
  class="summary"
  data-type="article"
  data-article-type="articles"
  data-premium="false"
  data-size="default"
>
    <a href="https://www.vg247.com/vampire-the-masquerade-bloodhunt-future-interview" class="link_overlay" title="More story, more communication, more content – how Sharkmob plans to support Bloodhunt for years to come" ></a>




<div class="thumbnail">
  <img
    src="https://asset.vg247.com/bloodhunt_future_header.jpg/BROK/thumbnail/299x168/format/jpg/quality/70/bloodhunt_future_header.jpg"
    srcset="https://asset.vg247.com/bloodhunt_future_header.jpg/BROK/thumbnail/299x168/format/jpg/quality/70/bloodhunt_future_header.jpg 1x, https://asset.vg247.com/bloodhunt_future_header.jpg/BROK/thumbnail/598x336/format/jpg/quality/70/bloodhunt_future_header.jpg 2x"
loading="lazy"    class="thumbnail_image"
    alt="Three vampires, running into the distance."
width="299"height="168"  >
</div>
    <div class="details">

            <div class="kicker_wrapper">
              <span class="kicker">Changing World</span>
            </div>

          <p class="title">
<a href="https://www.vg247.com/vampire-the-masquerade-bloodhunt-future-interview" >                More story, more communication, more content – how Sharkmob plans to support Bloodhunt for years to come
</a>          </p>

            <p class="strapline">In our final Bloodhunt interview, David Sirland talks us through what players can expect from the game&#39;s future.</p>

    </div>

    <div class="metadata">
    <span class="author">Connor Makar</span>

  <div class="article_data">
  <p class="comments">
      <a href="https://www.vg247.com/vampire-the-masquerade-bloodhunt-future-interview#comments">
    2
      </a>
  </p>
      <time class="published_at" datetime="2022-04-29 13:07:12.664983+00:00">
          5 hours ago

      </time>
  </div>
    </div>

</article>          </li>
          <li>




<article
  class="summary"
  data-type="article"
  data-article-type="articles"
  data-premium="false"
  data-size="default"
>
    <a href="https://www.vg247.com/trolley-problem-inc-feel-bad-gem" class="link_overlay" title="Trolley Problem, Inc is a brilliant, funny, feel-bad indie gem out now on Steam" ></a>




<div class="thumbnail">
  <img
    src="https://asset.vg247.com/trolley-problem-header.jpg/BROK/thumbnail/299x168/format/jpg/quality/70/trolley-problem-header.jpg"
    srcset="https://asset.vg247.com/trolley-problem-header.jpg/BROK/thumbnail/299x168/format/jpg/quality/70/trolley-problem-header.jpg 1x, https://asset.vg247.com/trolley-problem-header.jpg/BROK/thumbnail/598x336/format/jpg/quality/70/trolley-problem-header.jpg 2x"
loading="lazy"    class="thumbnail_image"
    alt="Image for Trolley Problem, Inc is a brilliant, funny, feel-bad indie gem out now on Steam"
width="299"height="168"  >
</div>
    <div class="details">

            <div class="kicker_wrapper">
              <span class="kicker">EVERYTHING IS FINE</span>
            </div>

          <p class="title">
<a href="https://www.vg247.com/trolley-problem-inc-feel-bad-gem" >                Trolley Problem, Inc is a brilliant, funny, feel-bad indie gem out now on Steam
</a>          </p>

            <p class="strapline">Now you can feel terrible grappling with philosophical, ethical questions on your PC.</p>

    </div>

    <div class="metadata">
    <span class="author">Alex Donaldson</span>

  <div class="article_data">
      <time class="published_at" datetime="2022-04-28 14:56:16.335260+00:00">
          1 day ago

      </time>
  </div>
    </div>

</article>          </li>
          <li>




<article
  class="summary"
  data-type="article"
  data-article-type="articles"
  data-premium="false"
  data-size="default"
>
    <a href="https://www.vg247.com/vampire-the-masquerade-bloodhunt-ps5-tech" class="link_overlay" title="“In-your-face functionality and immersion” Why Sharkmob chose PS5 for Vampire Bloodhunt’s lead platform" ></a>




<div class="thumbnail">
  <img
    src="https://asset.vg247.com/bloodhunt_tech_header.jpg/BROK/thumbnail/299x168/format/jpg/quality/70/bloodhunt_tech_header.jpg"
    srcset="https://asset.vg247.com/bloodhunt_tech_header.jpg/BROK/thumbnail/299x168/format/jpg/quality/70/bloodhunt_tech_header.jpg 1x, https://asset.vg247.com/bloodhunt_tech_header.jpg/BROK/thumbnail/598x336/format/jpg/quality/70/bloodhunt_tech_header.jpg 2x"
loading="lazy"    class="thumbnail_image"
    alt="A vampire looking over a fight in the streets."
width="299"height="168"  >
</div>
    <div class="details">

            <div class="kicker_wrapper">
              <span class="kicker">Fangs for the future</span>
            </div>

          <p class="title">
<a href="https://www.vg247.com/vampire-the-masquerade-bloodhunt-ps5-tech" >                “In-your-face functionality and immersion” Why Sharkmob chose PS5 for Vampire Bloodhunt’s lead platform
</a>          </p>

            <p class="strapline">In our second interview with the Sharkmob team, we discuss the technical side of the PS5&#39;s latest battle royale.</p>

    </div>

    <div class="metadata">
    <span class="author">Connor Makar</span>

  <div class="article_data">
  <p class="comments">
      <a href="https://www.vg247.com/vampire-the-masquerade-bloodhunt-ps5-tech#comments">
    3
      </a>
  </p>
      <time class="published_at" datetime="2022-04-28 13:00:36.126458+00:00">
          1 day ago

      </time>
  </div>
    </div>

</article>          </li>
      </ul>

  </section>




      <section class="shelf" data-count="4" >
    <div class="section_title_wrapper">
      <h2 class="section_title">Latest Articles</h2>
    </div>



      <ul class="summary_list">
          <li>




<article
  class="summary"
  data-type="article"
  data-article-type="news"
  data-premium="false"
  data-size="default"
>
    <a href="https://www.vg247.com/steam-is-going-rogue-next-week-with-the-festival-of-persistence-sale" class="link_overlay" title="Steam is going rogue next week with the Festival of Persistence sale" ></a>




<div class="thumbnail">
  <img
    src="https://asset.vg247.com/steam_going_rogue.jpg/BROK/thumbnail/299x168/format/jpg/quality/70/steam_going_rogue.jpg"
    srcset="https://asset.vg247.com/steam_going_rogue.jpg/BROK/thumbnail/299x168/format/jpg/quality/70/steam_going_rogue.jpg 1x, https://asset.vg247.com/steam_going_rogue.jpg/BROK/thumbnail/598x336/format/jpg/quality/70/steam_going_rogue.jpg 2x"
loading="lazy"    class="thumbnail_image"
    alt="Image for Steam is going rogue next week with the Festival of Persistence sale"
width="299"height="168"  >
</div>
    <div class="details">

            <div class="kicker_wrapper">
              <span class="kicker">TO DIE OR NOT TO DIE</span>
            </div>

          <p class="title">
<a href="https://www.vg247.com/steam-is-going-rogue-next-week-with-the-festival-of-persistence-sale" >                Steam is going rogue next week with the Festival of Persistence sale
</a>          </p>

            <p class="strapline">During the week you can enjoy discounts on current and upcoming roguelike games.</p>

    </div>

    <div class="metadata">
    <span class="author">Stephany Nunneley</span>

  <div class="article_data">
      <time class="published_at" datetime="2022-04-29 17:44:30.972258+00:00">
          an hour ago

      </time>
  </div>
    </div>

</article>          </li>
          <li>




<article
  class="summary"
  data-type="article"
  data-article-type="news"
  data-premium="false"
  data-size="default"
>
    <a href="https://www.vg247.com/cat-adventure-game-stray-set-for-summer-release-on-pc-playstation" class="link_overlay" title="Cat adventure game Stray set for summer release on PC, PlayStation" ></a>




<div class="thumbnail">
  <img
    src="https://asset.vg247.com/stray_ps5.jpg/BROK/thumbnail/299x168/format/jpg/quality/70/stray_ps5.jpg"
    srcset="https://asset.vg247.com/stray_ps5.jpg/BROK/thumbnail/299x168/format/jpg/quality/70/stray_ps5.jpg 1x, https://asset.vg247.com/stray_ps5.jpg/BROK/thumbnail/598x336/format/jpg/quality/70/stray_ps5.jpg 2x"
loading="lazy"    class="thumbnail_image"
    alt="Image for Cat adventure game Stray set for summer release on PC, PlayStation"
width="299"height="168"  >
</div>
    <div class="details">

            <div class="kicker_wrapper">
              <span class="kicker">HERE KITTY KITTY</span>
            </div>

          <p class="title">
<a href="https://www.vg247.com/cat-adventure-game-stray-set-for-summer-release-on-pc-playstation" >                Cat adventure game Stray set for summer release on PC, PlayStation
</a>          </p>

            <p class="strapline">Play as an adorable ginger cat in this adventure game from BlueTwelve Studio.</p>

    </div>

    <div class="metadata">
    <span class="author">Stephany Nunneley</span>

  <div class="article_data">
      <time class="published_at" datetime="2022-04-29 16:53:20.245903+00:00">
          an hour ago

      </time>
  </div>
    </div>

</article>          </li>
          <li>




<article
  class="summary"
  data-type="article"
  data-article-type="news"
  data-premium="false"
  data-size="default"
>
    <a href="https://www.vg247.com/call-of-duty-warzone-sniper-nerf-community-reaction" class="link_overlay" title="Warzone&#39;s Season 3 update has wasted the Sniper meta - here&#39;s the community reaction" ></a>




<div class="thumbnail">
  <img
    src="https://asset.vg247.com/warzone_sniper.jpg/BROK/thumbnail/299x168/format/jpg/quality/70/warzone_sniper.jpg"
    srcset="https://asset.vg247.com/warzone_sniper.jpg/BROK/thumbnail/299x168/format/jpg/quality/70/warzone_sniper.jpg 1x, https://asset.vg247.com/warzone_sniper.jpg/BROK/thumbnail/598x336/format/jpg/quality/70/warzone_sniper.jpg 2x"
loading="lazy"    class="thumbnail_image"
    alt="A Warzone operator, holding a sniper rifle"
width="299"height="168"  >
</div>
    <div class="details">

            <div class="kicker_wrapper">
              <span class="kicker">Boom, headshot</span>
            </div>

          <p class="title">
<a href="https://www.vg247.com/call-of-duty-warzone-sniper-nerf-community-reaction" >                Warzone&#39;s Season 3 update has wasted the Sniper meta - here&#39;s the community reaction
</a>          </p>

            <p class="strapline">Following some hard hitting patch notes with the latest season, snipers got hit hard. Here&#39;s the rundown on what exactly happened.</p>

    </div>

    <div class="metadata">
    <span class="author">Connor Makar</span>

  <div class="article_data">
      <time class="published_at" datetime="2022-04-29 16:52:10.429044+00:00">
          an hour ago

      </time>
  </div>
    </div>

</article>          </li>
          <li>




<article
  class="summary"
  data-type="article"
  data-article-type="guides"
  data-premium="false"
  data-size="default"
>
    <a href="https://www.vg247.com/elden-ring-best-armor" class="link_overlay" title="What is the best armor in Elden Ring for mages and melee?" ></a>




<div class="thumbnail">
  <img
    src="https://asset.vg247.com/elden-ring-best-armor-royal-remains.jpg/BROK/thumbnail/299x168/format/jpg/quality/70/elden-ring-best-armor-royal-remains.jpg"
    srcset="https://asset.vg247.com/elden-ring-best-armor-royal-remains.jpg/BROK/thumbnail/299x168/format/jpg/quality/70/elden-ring-best-armor-royal-remains.jpg 1x, https://asset.vg247.com/elden-ring-best-armor-royal-remains.jpg/BROK/thumbnail/598x336/format/jpg/quality/70/elden-ring-best-armor-royal-remains.jpg 2x"
loading="lazy"    class="thumbnail_image"
    alt="Image for What is the best armor in Elden Ring for mages and melee?"
width="299"height="168"  >
</div>
    <div class="details">


          <p class="title">
<a href="https://www.vg247.com/elden-ring-best-armor" >                What is the best armor in Elden Ring for mages and melee?
</a>          </p>

            <p class="strapline">Turtle up!</p>

    </div>

    <div class="metadata">
    <span class="author">James Billcliffe</span>

  <div class="article_data">
      <time class="published_at" datetime="2022-04-29 16:22:27.133103+00:00">
          2 hours ago

      </time>
  </div>
    </div>

</article>          </li>
      </ul>

  </section>





  <a
    href="https://store.reedpop.com/collections/vg247"
    class="merch_component "
    target="_blank"
    rel="noopener"
    title="Buy our t-shirts, yeah"
  >
    <div class="details">
        <img
          src="https://asset.vg247.com/0314_vg247-logo_3UB0dCn.png"
          alt="VG247 logo"
          loading="lazy"
        />
      <p class="title">Buy our t-shirts, yeah</p>
      <p class="strapline">They&#39;re far more stylish than your average video game website tat.</p>
      <button class="button">Explore our store</button>
    </div>
    <div class="asset">
      <img
        src="https://asset.vg247.com/0422_vg247-merch.png"
        alt="VG247 Merch"
        loading="lazy"
      />
    </div>
  </a>

  <script>
    buttons = document.querySelectorAll('.merch_component');
    for (i = 0; i < buttons.length; i++) {
      buttons[i].addEventListener('click', function(e) {
        gtag('event', 'click', {
          'event_category': 'Store Component',
          'event_label': window.location.href
        });
      });
    }
  </script>
      </div>
  </div>
            </div>

        </main>

        <footer class="app_footer">
  <div class="nav_wrapper">
      <div class="about">


<a
  href="/"
  class="logo"
  
>
    <img src="https://asset.vg247.com/0314_vg247-logo-inverse_xiNfZY6.svg" alt="VG247 logo" loading="eager">
</a>

  <form class="search_box" action="/search">
    <input type="text" name="q" aria-label="Search" placeholder="Search">
  </form>

  <p>Copyright © 2022 Gamer Network Limited, a ReedPop company.</p>
  <p>All rights reserved. No part of this site or its content may be reproduced without the permission of the copyright holder.</p>


  <nav class="social_follow">
    <ul class="social_list">
          <li>
            <a
              href="https://www.facebook.com/VG247"
              class="social_icon"
              data-type="facebook"
              data-action="follow"
                rel="noopener"
              target="_blank"
            >
                


      <span
      class="icon"
      data-icon="facebook-f"
      data-type="brands"
        title="Check us out on Facebook"
    ></span>


            </a>
          </li>
          <li>
            <a
              href="https://twitter.com/vg247"
              class="social_icon"
              data-type="twitter"
              data-action="follow"
                rel="noopener"
              target="_blank"
            >
                


      <span
      class="icon"
      data-icon="twitter"
      data-type="brands"
        title="Check us out on Twitter"
    ></span>


            </a>
          </li>
          <li>
            <a
              href="https://www.youtube.com/user/MrVg247"
              class="social_icon"
              data-type="youtube"
              data-action="follow"
                rel="noopener"
              target="_blank"
            >
                


      <span
      class="icon"
      data-icon="youtube"
      data-type="brands"
        title="Check us out on YouTube"
    ></span>


            </a>
          </li>
          <li>
            <a
              href="https://www.vg247.com/feed"
              class="social_icon"
              data-type="rss"
              data-action="follow"
                rel="alternate noopener"
                type="application/rss+xml"
              target="_blank"
            >
                


      <span
      class="icon"
      data-icon="rss"
      data-type="solid"
        title="Check out our RSS feed"
    ></span>


            </a>
          </li>
    </ul>
  </nav>
      </div>



  <nav class="nav_primary">
            <span class="label">Explore</span>


        <ul>
                  <li>
                    <a
                      href="/archive/news"
                      data-active="false"
                      
                    >
                        News
                    </a>
                  </li>
                  <li>
                    <a
                      href="/archive/reviews"
                      data-active="false"
                      
                    >
                        Reviews
                    </a>
                  </li>
                  <li>
                    <a
                      href="/archive/articles"
                      data-active="false"
                      
                    >
                        Articles
                    </a>
                  </li>
                  <li>
                    <a
                      href="/archive/guides"
                      data-active="false"
                      
                    >
                        Guides
                    </a>
                  </li>
        </ul>
  </nav>



  <nav class="nav_secondary">
            <span class="label">Popular Now</span>


        <ul>
                  <li>
                    <a
                      href="/topics/deals"
                      data-active="false"
                      
                    >
                        Deals
                    </a>
                  </li>
                  <li>
                    <a
                      href="/games/genshin-impact"
                      data-active="false"
                      
                    >
                        Genshin Impact
                    </a>
                  </li>
                  <li>
                    <a
                      href="/games/pokemon-go"
                      data-active="false"
                      
                    >
                        Pokémon Go
                    </a>
                  </li>
                  <li>
                    <a
                      href="/games/elden-ring"
                      data-active="false"
                      
                    >
                        Elden Ring
                    </a>
                  </li>
        </ul>
  </nav>



  <nav class="nav_helpful">
            <span class="label">Helpful Links</span>


        <ul>
                    <li>
                    <a
                      href="/about"
                      data-active="false"
                      
                    >
                        About Us
                    </a>
                  </li>
                  <li>
                    <a
                      href="/archive/2022/04"
                      data-active="false"
                      
                    >
                        Archive
                    </a>
                  </li>
                  <li>
                    <a
                      href="/authors"
                      data-active="false"
                      
                    >
                        Authors
                    </a>
                  </li>
                  <li>
                    <a
                      href="/code-of-conduct"
                      data-active="false"
                      
                    >
                        Code of Conduct
                    </a>
                  </li>
                  <li>
                    <a
                      href="mailto:contact@vg247.com"
                      data-active="false"
                      
                    >
                        Contact Us
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://privacy.rxglobal.com/en-gb/cookie-policy.html"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Cookie Policy
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.reedpop.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Corporate Site
                    </a>
                  </li>
                  <li>
                    <a
                      href="/editorial-policy"
                      data-active="false"
                      
                    >
                        Editorial Policy
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://privacy.rxglobal.com/en-gb/ccpa.html"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Notice to California Residents
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://privacy.rxglobal.com/en-gb.html"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Privacy Policy
                    </a>
                  </li>
                  <li>
                    <a
                      href="/review-policy"
                      data-active="false"
                      
                    >
                        Review Policy
                    </a>
                  </li>
                  <li>
                    <a
                      href="/terms-and-conditions"
                      data-active="false"
                      
                    >
                        Terms &amp; Conditions
                    </a>
                  </li>


      <li>
        <button class="optanon-show-settings">
Cookie Settings        </button>
      </li>
        </ul>
  </nav>



  <nav class="nav_sites">
            <span class="label">ReedPop</span>


        <ul>
                  <li>
                    <a
                      href="https://www.cosplaycentral.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Cosplay Central
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.dicebreaker.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Dicebreaker
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.eurogamer.net"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Eurogamer
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.gamesindustry.biz"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        GamesIndustry.biz
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.jelly.deals"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Jelly Deals
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.metabomb.net"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Metabomb
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.nintendolife.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Nintendo Life
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.pushsquare.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Push Square
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.rockpapershotgun.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        Rock Paper Shotgun
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.thehaul.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        The Haul
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.usgamer.net"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        USgamer
                    </a>
                  </li>
                  <li>
                    <a
                      href="https://www.videogameschronicle.com"
                      data-active="false"
                      target="_blank" rel="noopener"
                    >
                        VGC
                    </a>
                  </li>
        </ul>
  </nav>
  </div>
        </footer>
    </div>
  </body>
</html>